Resolved
All webhook performance is confirmed to be as expected now.
Monitoring
Performance has returned to normal levels, we are monitoring the situation.
Identified
We have identified delays in pipeline webhook processing in the US region. Customers will be seeing a delay in pipelines actions like propagation taking place